I want to login or register an account!
Results 1 to 6 of 6
  1. #1
    Neuer Benutzer
    Join Date
    08.09.2019
    Posts
    4

    Premium account not working

    Hello,


    So i wanted to buy a premium account via VISA card. Everything was okay till i clicked purchase. I was waiting for about 5 minutes and then it wrote CONNECTION TIMED OUT. Connection to the client server timed out. Maybe it doesn't work because its sunday? I tried now for a third time and still gives me the same problem. I wanted to buy it only for 1 month i hope it wont give me 3 now. thank you for your response.


    Timo

  2. #2
    Erfahrener Benutzer ZenTiac's Avatar
    Join Date
    25.01.2017
    Posts
    643
    Hi Timo10,
    It may just be that you have to try again later. If you have a PAYPAL account you could just use that as it usually deducts from your card anyways. I have no idea why it did not work for you. Hopefully it is just a slow weekend thing like you say.

    Kind Regards
    ZenTiac

  3. #3
    Neuer Benutzer
    Join Date
    08.09.2019
    Posts
    4
    Nope, still not working today..I tried 5 times and now when i click purchase it writes trides-cld.asseco-see.hr doesn't exist. Maybe because i'm from Slovenia and it's not working? I am trying to buy premium now for a 4th time and before I never had problems with it. I have still the same card. But it's true that last time when I bought premium was one year ago.
    Last edited by Timo10; 09.09.2019 at 15:41.

  4. #4
    Erfahrener Benutzer ZenTiac's Avatar
    Join Date
    25.01.2017
    Posts
    643
    May I ask what your steam id is please?
    I have passed the info you gave me to the owner. It might just be your end though. I have no idea why it is not working for you.
    Last edited by ZenTiac; 09.09.2019 at 16:34.

  5. #5
    Neuer Benutzer
    Join Date
    08.09.2019
    Posts
    4

  6. #6
    Neuer Benutzer
    Join Date
    08.09.2019
    Posts
    4
    Hey man so I tried again for 4 5 times and still nothing, so i created a PayPal account and it went through any complications, sorry that I didn't do that before but well now I create it and it works! :D Thank you ZenTiac for all your help, see you on servers! :)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •